Verification is currently underway for the maintenance items.
Posted Nov 13, 2025 - 21:56 CST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 21:00 CST
Scheduled
CyberLynk will perform planned maintenance on our Managed Voice routing.
What’s changing: • Compliance-related routing updates to CyberLynk Managed Voice.
Not affected: • TalkAnywhere Cloud UC • FreePBXHosting Servers
Customer impact: • We do not expect any customer impact.
Support: If you need assistance or have questions, please open a ticket at https://myaccount.cyberlynk.net. Our support team will be available during the window.
Posted Oct 30, 2025 - 13:53 CDT
This scheduled maintenance affected: MKE1 Hosted Application & Dedicated Services (Voice Over IP Services (MKE1)) and PHX1 Hosted Application & Dedicated Services (Voice Over IP Services (PHX1)).