MKE1 Upstream Provider Outage (Lumen)

Incident Report for CyberLynk Network

Resolved

This incident has been resolved.
Posted May 12, 2025 - 16:05 CDT

Monitoring

The outage has been resolved, and our team will work with the provider to determine the cause of the issue and continue monitoring for stability.
Posted May 12, 2025 - 15:49 CDT

Identified

One of our upstream providers in our Milwaukee data center is experiencing an outage and we are engaging them to address the issue. This outage may cause some temporary packet loss for some customers while traffic is being rerouted to our other providers.
Posted May 12, 2025 - 15:42 CDT
This incident affected: Upstream Network Providers (MKE1 - Lumen).