MKE1 Packet Loss

Incident Report for CyberLynk Network

Resolved

This incident has been resolved. For any customers experiencing unrelated issues, please open a support ticket and we'll be happy to assist. We thank you for your patience.
Posted May 31, 2026 - 22:54 CDT

Update

All services have been restored and we are continuing to monitor.
Posted May 31, 2026 - 22:19 CDT

Monitoring

Customers should begin seeing improvements as our NOC continues to mitigate this large scale attack. We will provide another update within one hour. Thank you for your patience.
Posted May 31, 2026 - 20:29 CDT

Update

We continue to work with our upstream providers to mitigate the issue.
Posted May 31, 2026 - 17:59 CDT

Identified

Our NOC has identified a DDoS attack impacting traffic at our MKE1 data center. We are working with our upstream providers to mitigate the issue and will continue to provide updates as information is available.
Posted May 31, 2026 - 16:24 CDT

Update

Our engineers have confirmed an issue causing high packet loss / latency at our MKE1 data center and are working on a resolution.
Posted May 31, 2026 - 14:43 CDT

Investigating

Our monitoring systems have detected a network outage in our MKE1 data center and an update will be provided shortly
Posted May 31, 2026 - 13:03 CDT
This incident affected: MKE1 Core Datacenter Infrastructure, Customer Portal and MKE1 Hosted Application & Dedicated Services (Voice Over IP Services (MKE1), Mac Hosting (MKE1), Web & Email Hosting (MKE1), File Sharing (MKE1)).