The upstream provider is continuing to isolate the fault and has engaged a splicing team. Our next update for this incident will be provided when there is an ETR or the fiber cut has been repaired.
Posted Jul 10, 2026 - 13:45 CDT
Update
The upstream provider is continuing to isolate the fiber fault.
Posted Jul 10, 2026 - 13:24 CDT
Update
The technicians have completed fiber light testing and have engaged Outside Plant Engineering (OSPE) for next steps.
Posted Jul 10, 2026 - 11:21 CDT
Update
Technicians are on site and have begun isolating the issue.
Posted Jul 10, 2026 - 10:07 CDT
Update
Our upstream provider suspects a fiber cut and has dispatched technicians to perform light level testing on the affected fiber span.
Posted Jul 10, 2026 - 07:46 CDT
Identified
One of our upstream providers in our Milwaukee data center is experiencing a regional outage and we are following their updates as they address the issue. Customers traversing this provider may have experienced a latency spike as traffic was automatically rerouted over our other providers.
Posted Jul 10, 2026 - 07:16 CDT
This incident affects: Upstream Network Providers (MKE1 - Lumen).