SBC Maintenance
Scheduled for Dec 3, 21:00 - 22:00 CST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 27, 2024 - 10:22 CST
Scheduled
Engineers are applying software patches to our VoIP calling infrastructure infrastructure. This is a transparent change, however calls in progress during the maintenance may experience slight degradation in call quality if they are active at the moment the changes are applied.

PBX Hosting customers are not impacted.
Posted Nov 27, 2024 - 10:22 CST
This scheduled maintenance affects: MKE1 Hosted Application & Dedicated Services (Voice Over IP Services (MKE1)) and PHX1 Hosted Application & Dedicated Services (Voice Over IP Services (PHX1)).