MKE1 Upstream Provider Outage

Incident Report for CyberLynk Network

Identified

The upstream provider has acknowledged the issue and is working to identify the problem. All customer traffic was automatically moved to other providers and we are continuing to monitor.
Posted Aug 26, 2026 - 14:37 CDT

Investigating

One of our upstream providers in our Milwaukee data center is experiencing an outage and we are following their updates as they address the issue. Customers traversing this provider may experience temporary latency/packet loss as traffic is automatically rerouted over our other providers.
Posted Aug 26, 2026 - 13:36 CDT
This incident affects: MKE1 Core Datacenter Infrastructure and Upstream Network Providers (MKE1 - Lumen).