CyberLynk Phone Support Not Available
Incident Report for CyberLynk Network
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 15:53 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2021 - 15:38 CDT
Investigating
We are aware of an issue affecting inbound sales/billing/support calls for customers and are currently investigating the issue.
Posted Aug 20, 2021 - 15:21 CDT
This incident affected: Customer Portal.